PSF
News: Read the news section about important information regarding site contacts.
 
Welcome, Guest. Please login or register.
Did you miss your activation email?
PSF  >  Community  >  Site News & Feedback  >  Topic: Bugs & Feature Requests 0 Members and 1 Guest are viewing this topic. « previous next »
Pages: < 1 2 3 4 5 6 7 8 9 10 [11] 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 ... 43 > Print
Author Topic: Bugs & Feature Requests  (Read 32137 times)
Death Blossom
Legendary Member
*******
Offline Offline

Posts: 15761


Leap'd on outta here


Email
« Reply #150 on: 2016-04-01 16:02:58 »

Yeah, the times we did chat there were pretty fun :)
Logged

yasl
Lead Tech
***
Offline Offline

Posts: 328



Email
« Reply #151 on: 2016-04-01 19:17:58 »

Oh okay, I think I found something a bit wonky. The little forward arrow shows up when you're looking at a board and all the threads. There's the double arrows, which have been there before, but like seen here http://imgur.com/7LwQtht there's an extra arrow. I don't think that's supposed to be there...

Applied a quick fix.  Hopefully won't have broken it elsewhere.

Also, Chat link was my derp.  Resolved.
Logged
1234
aka "Numbers"
Community Monitor
******
Offline Offline

Posts: 5155


WINDOWS FTW


WWW Email
« Reply #152 on: 2016-04-01 19:20:16 »

All right. ;)
Logged

Wanna know all about PSF's smileys? >>>CLICK HERE for a HUUUGE LIST<<<

Death Blossom
Legendary Member
*******
Offline Offline

Posts: 15761


Leap'd on outta here


Email
« Reply #153 on: 2016-04-01 21:36:15 »

Yeah, it looks good now! Thanks Yasl, always so quick to implement things we suggest haha.
Logged

yasl
Lead Tech
***
Offline Offline

Posts: 328



Email
« Reply #154 on: 2016-04-02 01:43:17 »

So far, they've all been 20 minute tweaks, so I've been able to squeeze them in without much hassle ;)
Logged
Death Blossom
Legendary Member
*******
Offline Offline

Posts: 15761


Leap'd on outta here


Email
« Reply #155 on: 2016-04-02 09:25:20 »

Wow, that's pretty impressive. In both ways. That you get them done so fast, and that coding little arrows takes 20 minutes! That's crazy.
Logged

Darrin
Administrator
*****
Offline Offline

Posts: 4895



Email
« Reply #156 on: 2016-04-02 11:30:01 »

Thank you Yasl.
Logged

:):):):):):):):):):)>>> "Green is the New You" -PSF <<<:):):):):):):(:):):)
Death Blossom
Legendary Member
*******
Offline Offline

Posts: 15761


Leap'd on outta here


Email
« Reply #157 on: 2016-04-02 14:54:50 »

Hey Yasl, sorry to bug you again so soon, but myself and a few others have noticed something a bit off about the avatars. You can't upload a gif to be an avatar. Like, if you have the gif saved on your device and try to upload it, it won't work. You have to upload the gif to an image uploading site (like imgur) and then use the "link avatar" function to actually make the gif work. Is that a bug or something? Is it possible to be able to upload gif avatars, or can the site not support that?
Logged

MasterXtreme
Legendary Member
*******
Offline Offline

Posts: 28179


PSF Member


Email
« Reply #158 on: 2016-04-02 20:25:40 »

I noticed that too. 
Logged
Grapefoot
Legendary Member
*******
Offline Offline

Posts: 10984


PSF Member


WWW Email
« Reply #159 on: 2016-04-03 07:25:49 »

Is there a way to link directly to a post? 
Logged

Death Blossom
Legendary Member
*******
Offline Offline

Posts: 15761


Leap'd on outta here


Email
« Reply #160 on: 2016-04-03 10:12:30 »

Yeah there is. You gotta right click on the "Re:Topic Post" of the post you're trying to directly link and copy the link. Each link is different when you do it for different posts so I assume that's a link to a direct post.
Logged

Smiles2us
Administrator
*****
Offline Offline

Posts: 4673



Email
« Reply #161 on: 2016-04-03 10:32:30 »

Is there a way to link directly to a post?

Also if you click on the "piece of paper" icon, next to the title of your post, it gives you the direct post link.
Logged
Death Blossom
Legendary Member
*******
Offline Offline

Posts: 15761


Leap'd on outta here


Email
« Reply #162 on: 2016-04-03 10:49:38 »

Oh so that's what that's for.
Logged

MasterXtreme
Legendary Member
*******
Offline Offline

Posts: 28179


PSF Member


Email
« Reply #163 on: 2016-04-03 12:18:07 »

All good to know, thanks guys. 
Logged
yasl
Lead Tech
***
Offline Offline

Posts: 328



Email
« Reply #164 on: 2016-04-07 08:00:56 »

Hey Yasl, sorry to bug you again so soon, but myself and a few others have noticed something a bit off about the avatars. You can't upload a gif to be an avatar. Like, if you have the gif saved on your device and try to upload it, it won't work. You have to upload the gif to an image uploading site (like imgur) and then use the "link avatar" function to actually make the gif work. Is that a bug or something? Is it possible to be able to upload gif avatars, or can the site not support that?

Ah, okay, that's apparently intended behavior.  Specifically, it's meant to be a security feature.  The forum re-encodes uploaded avatars by default but, due to a limitation in either the image library or the forum's use of it, doing so drops all but the first frame of animated GIFs (they're all munged into PNGs).

I expect the feature is designed primarily to prevent a scenario whereby a piece of Javascript (or perhaps some malicious executable) is uploaded and later executed in the context of the site, since the browser can't distinguish it from any other asset the site may serve.  This could let the malicious actor steal session cookies (& thus your account) or what-have-you.

The safest way to solve this problem is to place all user-uploaded content on its own domain, hence you get "googleusercontent.com" and "derpicdn.net".  The alternative is to make sure to only serve the images with an image-y MIME type, so the browser doesn't treat them as anything else.  Alas, there is a long history of browser bugs and quirks that make this method exploitable, and it tends to be more fragile.

However, since uploaded avatars and attachments are not directly accessible as files on the website, but served up through the forum software, I'm going to assume (1) the forum software is sensible and only serves avatars with image-y MIME types, (2) browsers have sorted out the majority of such bugs, and (3) attachments could probably be exploited the same way and yet aren't re-encoded.  And as such I've turned the re-encoding feature off.

Uh, let me know if it still doesn't work...
Logged
Pages: < 1 2 3 4 5 6 7 8 9 10 [11] 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 ... 43 > Print 
PSF  >  Community  >  Site News & Feedback  >  Topic: Bugs & Feature Requests « previous next »
Jump to:  


Login with username, password and session length

SMF 2.0.15 | SMF © 2017, Simple Machines | PSF © 2014-2019